solarforum
pro solar buso
livedaten solarberatung
heizung photovoltaik
 
 
  • UVR1611 Steuerung
  • Über uns

Das Solarforum von solar4me

Hallo Gast, Sie müssen sich einloggen um alle Funktionen des Forums nutzen zu können!
Registrieren   /    Passwort vergessen
Name: Passwort: Sec-code:
Programmierung der UVR1611 - Thema: solarsteuerung mit Pumpe mit 0-10V eingang
Moderatoren in diesem Forum: Oli-F
Das Solarforum von solar4me Programmierung der UVR1611 solarsteuerung mit Pumpe mit 0-10V eingang
zurück
Wählen Sie eine Seite: 1 2
Autor: Beitrag:
alexS alexS ist männlich
User

alexS ist offline

Beiträge: 51

zuletzt online:
31.10.2014 18:49 Uhr

solarsteuerung mit Pumpe mit 0-10V eingang
02.09.2012 14:56 Uhr

Hallo,
Hallo,

habe in meiner Solaranlage (11m²)eine modifizierte Laing-Pumpe (E4) deren Drehzahl ich mit einem 0-10V Sollwert steuern kann-(0V = kleinste Drehzahl; 10V= max. Drehzahl)
(Bei Interesse kann ich die Umbauanleitung gerne hier mal posten..)
Hydraulikschem siehe https://dl.dropbox.com/s/o39kjnfi1ss90rl/hydraulikschema_bild.gif
hättet Ihr einen Vorschlag wie ich die Pumpe am besten ansteuere?
Momentan habe ich die Ansteurung aus einem Beispiel übernommen..
Freigabe der 230V der Pumpe über Block: Solarregelung
und 0-10V über Block:PID_regelung
PID-Regler Parameter:
nur Absolutwertregelung mit T_abs.soll = 65°C, Modus=normal
nur P-Anteil mit 10

irgendwie schaffe ich es auch noch nicht, im Winsol den Wert der 0-10V Ausgänge zu loggen (über CAN-Bus)und sehe nur das die 65° Solltemperatur nie richtig eingeregelt werden (auch wenn genügend Sonne da wäre..)

Hat jemand so was ähnliche schon mal realisert?

Grüße
Alex
nitroxatmer nitroxatmer ist männlich
User

nitroxatmer ist offline

Beiträge: 1204
Herkunft: Gera
Beruf: Experte für Regelungen und Steuerungen
zuletzt online:
10.05.2020 22:18 Uhr

Re: solarsteuerung mit Pumpe mit 0-10V eingang
02.09.2012 21:09 Uhr

Servus.
Meine Pumpe regle ich über PWM aus, was das selbe Problem wie Deines mit sich brachte.
Zum einen solltest Du mit I und D um die 3/4 variieren/probieren.
Zum anderen ändert sich bei der 0-10V -Ansteuerung der Volumenstrom der Pumpe wesentlich lienearer als bei der Ansteuerung einer "gewöhnlichen" Pumpe.
Das kann über die Parametrierung des Ausgangs angepasst werden. Dort kannst Du festlegen,welcher Drehzahstufe der PID welche Ausgangsspannung entspricht.

Zum loggen der 0-10V gab es für mich noch keinen Bedarf- wenn Du weiß wie es geht, lass es uns bitte wissen !!

Beste Grüße
Holger
Ich hoffe, man kann meinen Gedanken folgen -die sind irgendwie schneller als ich schreiben kann....

Auch wenn es nur Worte sind- ein Danke kommt immer gut an! ;)

UND: bitte gebt zum Schluß auch die Lösung Eures Problems weiter - nur dann hilft es auch Anderen !!
Johannes Johannes ist männlich
User

Johannes ist offline

Beiträge: 84

zuletzt online:
16.07.2017 11:56 Uhr

Re: solarsteuerung mit Pumpe mit 0-10V eingang
03.09.2012 21:08 Uhr

hallo, analoge Ausgänge können nicht geloggt werden, bei Winsol,
im onlineschema können sie angezeigt werden, leider.
ich betreibe 3 Pumpen mit dem 0-10V signal, aber ich würde den
P anteil verringern und den I anteil erhöhen, den D anteil ebenfalls,
ist natürlich abhängig von der rohrlänge zum Kollektor.
es ist relativ schwierig dies herauszufinden, was optimal ist,
hab auch lange probiert,
warum eigentlich absolutwertreglung so hoch, und keine Differenzreglung zusätzlich?
gruss Hannes

Beitrag wurde 1 mal bearbeitet, zuletzt von johannes am 03.09.2012 21:08 Uhr
alexS alexS ist männlich
User

alexS ist offline

Beiträge: 51

zuletzt online:
31.10.2014 18:49 Uhr

Re: solarsteuerung mit Pumpe mit 0-10V eingang
03.09.2012 23:08 Uhr

Hallo Johannes,

Danke für die Info zum Winsol... dann brauch ich da nicht länger probieren..
Die Ausgänge der PID-Regler kann mann auch nicht loggen, oder? (oder mache ich da nur was falsch?
ZU deienr Frage: Wie bin ich zu meiner Reglerauslegung gekommen?
Hab mir gedacht ich fange erstmal mit der einfachst möglichen Lösung an (nur Konstantreglung mit nur P-Anteil), und wenn ich das verstanden habe, bzw. optimierungstechnisch an die Grenzen gestoßen bin schalte ich die nächste Stufe zu...
Wollte eigentlich wie in der UVR1611 Anleitung beschrieben vorgehen und den P-anteil so weit vergrößern bzw. den Parameter veringern bis der Regelkreis schwingt..
Aber wie sehe ich das vernünftig, ohne das ich die Stellgröße aufzeichnen kann? Hast du die über einen extenen analogen Datenlogger/Oszi gemessen?
Wie habt Ihr überhaupt eure Normierung gewählt?
Ich lasse den Regler ein Stellsignal von 20 bis 100(%) zu? (Unter 20 bewegt sich der Schwebekörper im Druchflusssensor nicht, obwohl die Pumpe sauber dreht..)
und ich habe 0% =0V und 100% = 10V am Ausgang parametriert?
Fritz Fritz ist männlich
User

Fritz ist offline

Beiträge: 11

zuletzt online:
06.09.2015 9:23 Uhr

Re: solarsteuerung mit Pumpe mit 0-10V eingang
05.09.2012 21:23 Uhr

Hi,

man kann duchaus die Daten des 0-10V Ausgangs loggen. Allerdings nicht ohne einen Umweg und ein Trick ist auch noch nötig.

Du musst beim Datenlogging statt der default Werte einen der 16 Werte umdefinieren und auf z.B. das Ergebnis Deines PID Reglers legen (gleiche Funktion wie Du auf den 0-10V Ausgang gelegt hast). Dann erscheint dieser im 2. Datenrahmen von Winsol, allerdings nur wenn als Einheit eine Verwendet wird die Winsol kennt und das ist der Trick einfach °C einstellen und es geht. Stellst Du Spannung ein geht's nicht. Das hat mich Monate gekostet bis ich da per Zufall drauf gekommen bin. Ich hab wirklich alle Umwege dieser Welt probiert über Netzwerkausgänge usw. geht alles nicht.

Das gleiche Problem gibt es übrigens bei 0-10V Eingängen. Bei mir läuft noch ein Bajorath Regler der über zwei 0-10V Ausgänge den Brenner und eine Mischer steuert und ich bin fast durchgedreht bis ich den loggen konnte.

probiers mal, Rückmeldung wäre toll
alexS alexS ist männlich
User

alexS ist offline

Beiträge: 51

zuletzt online:
31.10.2014 18:49 Uhr

Re: solarsteuerung mit Pumpe mit 0-10V eingang
05.09.2012 22:14 Uhr

Hallo,

habe gestern abend von TA eine Antwort auf die Frage 0-10V Ausgänge datenloggen bekommen:

"
Die beiden 0-10V Ausgänge mitzuloggen ist jedoch etwas schwieriger. Sie müssten das Ergebnis der PID-Regelung mit der der Ausgang angesteuert wird mit einer zusätzlichen Analogfunktion einlesen. Anschließend können Sie diesen Wert mit der falschen physikalischen Einheit (z.B. °C) einen beliebigen analogen (Netzwerk datenlogging)-Wert zuweisen (bei TAPPS unter "Datei - CAN-Datenlogging";). Nun wird über diesen analogen Wert ein Temperatursignal mitgeloggt welches Ihrer Analogstufe entspricht. Wenn hier z.B. 4,6°C angezeigt werden würde dies 4,6V entsprechen (Bei einer Skalierung von 0...100 entspricht 0V...10.0V)
"

habe es ausprobiert und es scheint zu funktionieren..
alexS alexS ist männlich
User

alexS ist offline

Beiträge: 51

zuletzt online:
31.10.2014 18:49 Uhr

Re: solarsteuerung mit Pumpe mit 0-10V eingang
05.09.2012 22:49 Uhr

Hallo Fritz,
danke für den Tip,
werde ich bei der nächsten Änderugn in meinem Tapp-Programm mal ausprobieren..
Denke das ich morgen eine Rückmeldung geben kann.
Grüße Alex

alexS hat folgende Dateien angehängt:
Bild wurde verkleinert, anklicken für Originalgröße!
alexS alexS ist männlich
User

alexS ist offline

Beiträge: 51

zuletzt online:
31.10.2014 18:49 Uhr

Re: solarsteuerung mit Pumpe mit 0-10V eingang
05.09.2012 23:02 Uhr

Hallo Fritz,

wo kann ich denn für den PID-Regler-Ausgang,
die Einheit °C einstellen?
Habe die weder in den

* parametern des PID-Reglers,
* im Tapps-CAN-Datenlogging Menü
* noch im Winsol gefunden..

-> kann es sein das es ohne eine zusätzliche Analogfunktion doch nicht geht?
Fritz Fritz ist männlich
User

Fritz ist offline

Beiträge: 11

zuletzt online:
06.09.2015 9:23 Uhr

Re: solarsteuerung mit Pumpe mit 0-10V eingang
06.09.2012 9:46 Uhr

Hallo alexS,

ich bin mir nicht mehr sicher wo man das einstellen konnte, schau ich noch nach bin aber gerade nicht Zuhause.
Bei mir läuft das auf jeden Fall über eine Analogfunktion, da ich aus den zwei 0-10V Eingängen + eigene Funktionen ein 0-10V Ausgang über eine MAX Funktion ansteuere. So hab ich gar nicht gemerkt, dass die nötig ist.

Auf dem Bild ist doch ein 0-10V Wert geloggt, geht also, zwar mit Umweg aber geht.
Bei dem Loggen von Analogeingängen die auf Spannung gesetzt sind ist es leider auch etwas komisch. DL-Bus loggen geht, CAN nicht, außer man stellt die Einheiten auf was anderes. Ursach muss wohl in Winsol liegen, da es im Online-Schema geht.

Gruss Fritz

Beitrag wurde 2 mal bearbeitet, zuletzt von Fritz am 06.09.2012 10:00 Uhr
alexS alexS ist männlich
User

alexS ist offline

Beiträge: 51

zuletzt online:
31.10.2014 18:49 Uhr

Re: solarsteuerung mit Pumpe mit 0-10V eingang
06.09.2012 21:17 Uhr

Hallo,
habe zu dem Thema 0-10V logging eine kurze bebilderte Anleitung geschrieben

alexS hat folgende Dateien angehängt:
0-10V_Datenlogging_mit_winsol.doc , Größe: 0,36 MB
nitroxatmer nitroxatmer ist männlich
User

nitroxatmer ist offline

Beiträge: 1204
Herkunft: Gera
Beruf: Experte für Regelungen und Steuerungen
zuletzt online:
10.05.2020 22:18 Uhr

Re: solarsteuerung mit Pumpe mit 0-10V eingang
06.09.2012 21:35 Uhr

coole Sache,die Beschreibung, alex!

Beitrag wurde 1 mal bearbeitet, zuletzt von nitroxatmer am 07.09.2012 8:54 Uhr
Ich hoffe, man kann meinen Gedanken folgen -die sind irgendwie schneller als ich schreiben kann....

Auch wenn es nur Worte sind- ein Danke kommt immer gut an! ;)

UND: bitte gebt zum Schluß auch die Lösung Eures Problems weiter - nur dann hilft es auch Anderen !!
Wählen Sie eine Seite: 1 2
zurück
 
 
Powered by eASY-CMS www.space-discount.net © Dennis Spiegel 2020